summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorsntx <[email protected]>2024-04-10 17:55:22 +0200
committerGitHub <[email protected]>2024-04-10 11:55:22 -0400
commit167a4ea0aec93d51e4c606ffdbe3a195d12da6e3 (patch)
tree9913da2040e6011008bf93e09f8245399e747868 /flake.nix
parent8afe66ab31038165916a96c88b4a1f9a48f0dd1d (diff)
fix: Changes outputs, `nix flake show` now completes (#280)
Removed the `default` attribute from `outputs.formatter.<system>`, instead parse the formatter derivation directly. This fixes the issue that `nix flake show` doesn't complete. Co-authored-by: sntx <[email protected]>
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index d71313cf..7af8fe82 100644
--- a/flake.nix
+++ b/flake.nix
@@ -60,8 +60,6 @@
}
);
- formatter = nixpkgs.lib.genAttrs targetSystems (system: {
- default = (pkgsFor system).nixfmt-rfc-style;
- });
+ formatter = nixpkgs.lib.genAttrs targetSystems (system: (pkgsFor system).nixfmt-rfc-style);
};
}