summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 75c7a7b..e96f2e6 100644
--- a/meson.build
+++ b/meson.build
@@ -107,9 +107,15 @@ wayland_server = dependency('wayland-server',
)
wlroots_options = [ 'examples=false' ]
+wlroots_version = ['>=0.16.0', '<0.17.0']
+subproject(
+ 'wlroots',
+ default_options: wlroots_options,
+ required: false,
+ version: wlroots_version,
+)
wlroots = dependency('wlroots',
- version: '0.16.2',
- fallback: 'wayland',
+ version: wlroots_version,
default_options: wlroots_options,
)