summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorErik Reider <[email protected]>2023-07-13 14:55:28 +0200
committerWilliam McKinnon <[email protected]>2023-07-18 13:14:53 -0400
commitd462d952de20bdb7c3c84b05ed94d15b07ee5116 (patch)
tree7cbe0e380c6c130495a30d8728365ab49cc4d956 /meson.build
parent920c3c70d20e58b4af5a7abe52b24f47b90bc575 (diff)
feat: initial fx_renderer implementation
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 75c7a7b..e96f2e6 100644
--- a/meson.build
+++ b/meson.build
@@ -107,9 +107,15 @@ wayland_server = dependency('wayland-server',
)
wlroots_options = [ 'examples=false' ]
+wlroots_version = ['>=0.16.0', '<0.17.0']
+subproject(
+ 'wlroots',
+ default_options: wlroots_options,
+ required: false,
+ version: wlroots_version,
+)
wlroots = dependency('wlroots',
- version: '0.16.2',
- fallback: 'wayland',
+ version: wlroots_version,
default_options: wlroots_options,
)