diff options
author | William McKinnon <[email protected]> | 2023-07-12 01:23:05 -0400 |
---|---|---|
committer | GitHub <[email protected]> | 2023-07-12 01:23:05 -0400 |
commit | 120ddde3b1c6343b99ecfb790f15ffbe23c8c2b5 (patch) | |
tree | eeb9685137d95e888a6b98785109b9f3d9129a59 /flake.nix | |
parent | 9eaa07a4b141bc80a46cb7ab2dc94048f126fa8c (diff) | |
parent | 2388e30bd5ef01ab67d6be769743da3e830f59c4 (diff) |
Merge pull request #4 from Shinyzenith/main
Sucessfully compile libscenefx and tinywl
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 28 |
1 files changed, 12 insertions, 16 deletions
@@ -19,33 +19,29 @@ }; targetSystems = [ "aarch64-linux" "x86_64-linux" ]; - in - { + in { devShells = nixpkgs.lib.genAttrs targetSystems (system: - let - pkgs = pkgsFor system; - in - { + let pkgs = pkgsFor system; + in { default = pkgs.mkShell { name = "scenefx-shell"; - depsBuildBuild = with pkgs; [ pkg-config ]; - inputsFrom = [ pkgs.wlroots_0_16 ]; - nativeBuildInputs = with pkgs; [ cmake meson ninja + scdoc pkg-config + + wayland wayland-scanner - scdoc + wayland-protocols + wlroots_0_16 hwdata + udev + pixman + libxkbcommon + libdrm ]; - -# shellHook = with pkgs; ''( -# mkdir -p "$PWD/subprojects" -# cd "$PWD/subprojects" -# cp -R --no-preserve=mode,ownership ${wlroots_0_16.src} wlroots -# )''; }; }); }; |