summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorWilliam McKinnon <[email protected]>2023-07-11 00:44:26 -0400
committerWilliam McKinnon <[email protected]>2023-07-11 00:44:26 -0400
commit9eaa07a4b141bc80a46cb7ab2dc94048f126fa8c (patch)
treec78cb64199476b94d9ee2f403f1e31ff4d3c5a69 /flake.nix
parent74e85d896e4e0964a93113cd9ef31bfb10747b28 (diff)
added more scene dependencies, added tinywl
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix53
1 files changed, 53 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..a6b50a6
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,53 @@
+{
+ description = "scenefx development environment";
+
+ inputs = {
+ flake-compat = {
+ url = "github:edolstra/flake-compat";
+ flake = false;
+ };
+
+ nixpkgs.url = "github:nixos/nixpkgs/nixpkgs-unstable";
+ };
+
+ outputs = { self, nixpkgs, flake-compat, ... }:
+ let
+ pkgsFor = system:
+ import nixpkgs {
+ inherit system;
+ overlays = [ ];
+ };
+
+ targetSystems = [ "aarch64-linux" "x86_64-linux" ];
+ in
+ {
+ devShells = nixpkgs.lib.genAttrs targetSystems (system:
+ let
+ pkgs = pkgsFor system;
+ in
+ {
+ default = pkgs.mkShell {
+ name = "scenefx-shell";
+ depsBuildBuild = with pkgs; [ pkg-config ];
+ inputsFrom = [ pkgs.wlroots_0_16 ];
+
+ nativeBuildInputs = with pkgs; [
+ cmake
+ meson
+ ninja
+ pkg-config
+ wayland-scanner
+ scdoc
+ hwdata
+ ];
+
+# shellHook = with pkgs; ''(
+# mkdir -p "$PWD/subprojects"
+# cd "$PWD/subprojects"
+# cp -R --no-preserve=mode,ownership ${wlroots_0_16.src} wlroots
+# )'';
+ };
+ });
+ };
+}
+