summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 00000000..4ccc1cb9
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,25 @@
+let
+ unstableTarball = fetchTarball https://github.com/NixOS/nixpkgs/archive/nixos-unstable.tar.gz;
+ pkgs = import <nixpkgs> {};
+ unstable = import unstableTarball {};
+
+ shell = pkgs.mkShell {
+ depsBuildBuild = with unstable; [
+ pkg-config
+ ];
+
+ nativeBuildInputs = with unstable; [
+ cmake meson ninja pkg-config wayland-scanner scdoc
+ ];
+
+ buildInputs = with unstable; [
+ wayland libxkbcommon pcre json_c libevdev
+ pango cairo libinput libcap pam gdk-pixbuf librsvg
+ wayland-protocols libdrm wlroots dbus xwayland
+
+ # wlroots
+ libGL pixman xorg.xcbutilwm xorg.libX11 libcap xorg.xcbutilimage xorg.xcbutilerrors mesa
+ libpng ffmpeg xorg.xcbutilrenderutil seatd
+ ];
+ };
+in shell