summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/shell.nix b/shell.nix
deleted file mode 100644
index 4ccc1cb9..00000000
--- a/shell.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-let
- unstableTarball = fetchTarball https://github.com/NixOS/nixpkgs/archive/nixos-unstable.tar.gz;
- pkgs = import <nixpkgs> {};
- unstable = import unstableTarball {};
-
- shell = pkgs.mkShell {
- depsBuildBuild = with unstable; [
- pkg-config
- ];
-
- nativeBuildInputs = with unstable; [
- cmake meson ninja pkg-config wayland-scanner scdoc
- ];
-
- buildInputs = with unstable; [
- wayland libxkbcommon pcre json_c libevdev
- pango cairo libinput libcap pam gdk-pixbuf librsvg
- wayland-protocols libdrm wlroots dbus xwayland
-
- # wlroots
- libGL pixman xorg.xcbutilwm xorg.libX11 libcap xorg.xcbutilimage xorg.xcbutilerrors mesa
- libpng ffmpeg xorg.xcbutilrenderutil seatd
- ];
- };
-in shell