summaryrefslogtreecommitdiff
path: root/protocols/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/meson.build')
-rw-r--r--protocols/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/protocols/meson.build b/protocols/meson.build
index 904aead4..2992ac58 100644
--- a/protocols/meson.build
+++ b/protocols/meson.build
@@ -2,7 +2,7 @@ wl_protocol_dir = wayland_protos.get_variable('pkgdatadir')
wayland_scanner_dep = dependency('wayland-scanner', native: true)
wayland_scanner = find_program(
- wayland_scanner_dep.get_variable(pkgconfig: 'wayland_scanner'),
+ wayland_scanner_dep.get_variable('wayland_scanner'),
native: true,
)
@@ -12,6 +12,8 @@ protocols = [
wl_protocol_dir / 'unstable/pointer-constraints/pointer-constraints-unstable-v1.xml',
wl_protocol_dir / 'unstable/tablet/tablet-unstable-v2.xml',
wl_protocol_dir / 'unstable/linux-dmabuf/linux-dmabuf-unstable-v1.xml',
+ wl_protocol_dir / 'staging/content-type/content-type-v1.xml',
+ wl_protocol_dir / 'staging/cursor-shape/cursor-shape-v1.xml',
'wlr-layer-shell-unstable-v1.xml',
'idle.xml',
'wlr-input-inhibitor-unstable-v1.xml',