summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 00000000..29fe7727
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,34 @@
+{
+ description = "swaywm development environment";
+
+ inputs = {
+ nixpkgs.url = "nixpkgs/nixpkgs-unstable";
+ flake-utils = { url = "github:numtide/flake-utils"; };
+ };
+
+ outputs = {self, nixpkgs, flake-utils }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ pkgs = import nixpkgs { inherit system; };
+
+ in {
+ devShell = pkgs.mkShell {
+ depsBuildBuild = with pkgs; [
+ pkg-config
+ ];
+
+ nativeBuildInputs = with pkgs; [
+ cmake meson ninja pkg-config wayland-scanner scdoc
+ ];
+
+ buildInputs = with pkgs; [
+ wayland libxkbcommon pcre json_c libevdev pango cairo libinput libcap pam gdk-pixbuf librsvg
+ wayland-protocols libdrm wlroots dbus xwayland
+ # wlroots
+ libGL pixman xorg.xcbutilwm xorg.libX11 libcap xorg.xcbutilimage xorg.xcbutilerrors mesa
+ libpng ffmpeg xorg.xcbutilrenderutil seatd
+ ];
+ };
+ }
+ );
+}