summaryrefslogtreecommitdiff
path: root/build-scripts/swayfx.rpkg.spec
diff options
context:
space:
mode:
Diffstat (limited to 'build-scripts/swayfx.rpkg.spec')
-rw-r--r--build-scripts/swayfx.rpkg.spec18
1 files changed, 14 insertions, 4 deletions
diff --git a/build-scripts/swayfx.rpkg.spec b/build-scripts/swayfx.rpkg.spec
index 18b233a7..b69f0882 100644
--- a/build-scripts/swayfx.rpkg.spec
+++ b/build-scripts/swayfx.rpkg.spec
@@ -1,7 +1,14 @@
# vim: syntax=spec
+
+### CHANGE THESE VARIABLES BEFORE RELEASE:
+# Change to current Sway base version!
+%global SwayBaseVersion 1.7
+# Change to current SwayFX tag!
+%global Tag 0.1
+
Name: {{{ git_dir_name }}}
-Version: 0.1
-Release: 1%{?dist}
+Version: %{Tag}
+Release: 2%{?dist}
Summary: SwayFX: Sway, but with eye candy!
License: MIT
URL: https://github.com/WillPower3309/swayfx
@@ -58,6 +65,9 @@ Recommends: foot
Recommends: grim
%{?systemd_requires}
+Conflicts: sway
+Provides: sway = %{SwayBaseVersion}
+
%description
SwayFX: Sway, but with eye candy!
@@ -89,8 +99,8 @@ interface.
%build
%meson \
- -Dsd-bus-provider=libsystemd \
- -Dwerror=false
+ -Dsd-bus-provider=libsystemd \
+ -Dwerror=false
%meson_build