summaryrefslogtreecommitdiff
path: root/build-scripts/aur/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'build-scripts/aur/PKGBUILD')
-rw-r--r--build-scripts/aur/PKGBUILD78
1 files changed, 0 insertions, 78 deletions
diff --git a/build-scripts/aur/PKGBUILD b/build-scripts/aur/PKGBUILD
deleted file mode 100644
index 316b1a85..00000000
--- a/build-scripts/aur/PKGBUILD
+++ /dev/null
@@ -1,78 +0,0 @@
-# Maintainer: Erik Reider <[email protected]>
-_pkgname=swayfx
-pkgname="$_pkgname"
-pkgver=0.3.2
-pkgrel=5
-license=("MIT")
-pkgdesc="SwayFX: Sway, but with eye candy!"
-makedepends=(
- "git"
- "meson"
- "scdoc"
- "wayland-protocols"
-)
-depends=(
- "cairo"
- "gdk-pixbuf2"
- "libevdev.so"
- "libinput"
- "libjson-c.so"
- "libudev.so"
- "libwayland-server.so"
- "libwlroots.so=11"
- "libxcb"
- "libxkbcommon.so"
- "pango"
- "pcre2"
- "ttf-font"
-)
-optdepends=(
- "alacritty: Terminal emulator used by the default config"
- "dmenu: Application launcher"
- "grim: Screenshot utility"
- "i3status: Status line"
- "mako: Lightweight notification daemon"
- "slurp: Select a region"
- "swayidle: Idle management daemon"
- "swaylock: Screen locker"
- "wallutils: Timed wallpapers"
- "waybar: Highly customizable bar"
- "xdg-desktop-portal-gtk: Default xdg-desktop-portal for file picking"
- "xdg-desktop-portal-wlr: xdg-desktop-portal backend"
-)
-backup=(etc/sway/config)
-arch=("i686" "x86_64")
-url="https://github.com/WillPower3309/swayfx"
-source=("${_pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/$pkgver.tar.gz"
- 50-systemd-user.conf
- sway-portals.conf)
-sha512sums=(
- "SKIP"
- "d5f9aadbb4bbef067c31d4c8c14dad220eb6f3e559e9157e20e1e3d47faf2f77b9a15e52519c3ffc53dc8a5202cb28757b81a4b3b0cc5dd50a4ddc49e03fe06e"
- "790741df028822bf4d83170dea57e1c63f7d7938cf31969e4cd347b0fc07330322b603c9ec0091b7a3f425132bed9dee6f261074cc273555120858beaaaf5da1")
-provides=("sway" "swayfx")
-conflicts=("sway" "swayfx")
-options=(debug)
-install=sway.install
-
-build() {
- export PKG_CONFIG_PATH='/usr/lib/wlroots0.16/pkgconfig'
- arch-meson \
- -Dwerror=false \
- -Dsd-bus-provider=libsystemd \
- "${_pkgname}-${pkgver}" build
- meson compile -C build
-}
-
-package() {
- install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
- install -Dm644 sway-portals.conf "$pkgdir/usr/share/xdg-desktop-portal/sway-portals.conf"
-
- DESTDIR="$pkgdir" meson install -C build
-
- cd "${_pkgname}-${pkgver}"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- for util in autoname-workspaces.py inactive-windows-transparency.py grimshot; do
- install -Dm755 "contrib/$util" -t "$pkgdir/usr/share/$pkgname/scripts"
- done
-}