summaryrefslogtreecommitdiff
path: root/build-scripts/aur-git
diff options
context:
space:
mode:
Diffstat (limited to 'build-scripts/aur-git')
-rw-r--r--build-scripts/aur-git/50-systemd-user.conf16
-rw-r--r--build-scripts/aur-git/PKGBUILD83
-rw-r--r--build-scripts/aur-git/sway-portals.conf6
-rw-r--r--build-scripts/aur-git/sway.install31
4 files changed, 0 insertions, 136 deletions
diff --git a/build-scripts/aur-git/50-systemd-user.conf b/build-scripts/aur-git/50-systemd-user.conf
deleted file mode 100644
index 8781db92..00000000
--- a/build-scripts/aur-git/50-systemd-user.conf
+++ /dev/null
@@ -1,16 +0,0 @@
-# sway does not set DISPLAY/WAYLAND_DISPLAY in the systemd user environment
-# See FS#63021
-# Adapted from xorg's 50-systemd-user.sh, which achieves a similar goal.
-
-# Upstream refuses to set XDG_CURRENT_DESKTOP so we have to.
-exec systemctl --user set-environment XDG_CURRENT_DESKTOP=sway
-exec systemctl --user import-environment DISPLAY \
- SWAYSOCK \
- WAYLAND_DISPLAY \
- XDG_CURRENT_DESKTOP
-
-exec hash dbus-update-activation-environment 2>/dev/null && \
- dbus-update-activation-environment --systemd DISPLAY \
- SWAYSOCK \
- XDG_CURRENT_DESKTOP=sway \
- WAYLAND_DISPLAY
diff --git a/build-scripts/aur-git/PKGBUILD b/build-scripts/aur-git/PKGBUILD
deleted file mode 100644
index 585a8c05..00000000
--- a/build-scripts/aur-git/PKGBUILD
+++ /dev/null
@@ -1,83 +0,0 @@
-# Maintainer: Erik Reider <[email protected]>
-_pkgname=swayfx
-pkgname="$_pkgname-git"
-pkgver=r7023.9cd02fc4
-pkgrel=5
-license=("MIT")
-pkgdesc="SwayFX: Sway, but with eye candy!"
-makedepends=(
- "git"
- "meson"
- "scdoc"
- "wayland-protocols"
-)
-depends=(
- "cairo"
- "gdk-pixbuf2"
- "libevdev.so"
- "libinput"
- "libjson-c.so"
- "libudev.so"
- "libwayland-server.so"
- "libwlroots.so=11"
- "libxcb"
- "libxkbcommon.so"
- "pango"
- "pcre2"
- "ttf-font"
-)
-optdepends=(
- "alacritty: Terminal emulator used by the default config"
- "dmenu: Application launcher"
- "grim: Screenshot utility"
- "i3status: Status line"
- "mako: Lightweight notification daemon"
- "slurp: Select a region"
- "swayidle: Idle management daemon"
- "swaylock: Screen locker"
- "wallutils: Timed wallpapers"
- "waybar: Highly customizable bar"
- "xdg-desktop-portal-gtk: Default xdg-desktop-portal for file picking"
- "xdg-desktop-portal-wlr: xdg-desktop-portal backend"
-)
-backup=(etc/sway/config)
-arch=("i686" "x86_64")
-url="https://github.com/WillPower3309/swayfx"
-source=("${pkgname%-*}::git+${url}.git"
- 50-systemd-user.conf
- sway-portals.conf)
-sha512sums=(
- "SKIP"
- "d5f9aadbb4bbef067c31d4c8c14dad220eb6f3e559e9157e20e1e3d47faf2f77b9a15e52519c3ffc53dc8a5202cb28757b81a4b3b0cc5dd50a4ddc49e03fe06e"
- "790741df028822bf4d83170dea57e1c63f7d7938cf31969e4cd347b0fc07330322b603c9ec0091b7a3f425132bed9dee6f261074cc273555120858beaaaf5da1")
-provides=("sway" "swayfx")
-conflicts=("sway" "swayfx")
-options=(debug)
-install=sway.install
-
-pkgver() {
- cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
-build() {
- export PKG_CONFIG_PATH='/usr/lib/wlroots0.16/pkgconfig'
- arch-meson \
- -Dwerror=false \
- -Dsd-bus-provider=libsystemd \
- "$_pkgname" build
- meson compile -C build
-}
-
-package() {
- install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
- install -Dm644 sway-portals.conf "$pkgdir/usr/share/xdg-desktop-portal/sway-portals.conf"
-
- DESTDIR="$pkgdir" meson install -C build
-
- cd "$_pkgname"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- for util in autoname-workspaces.py inactive-windows-transparency.py grimshot; do
- install -Dm755 "contrib/$util" -t "$pkgdir/usr/share/$pkgname/scripts"
- done
-}
diff --git a/build-scripts/aur-git/sway-portals.conf b/build-scripts/aur-git/sway-portals.conf
deleted file mode 100644
index aa046f63..00000000
--- a/build-scripts/aur-git/sway-portals.conf
+++ /dev/null
@@ -1,6 +0,0 @@
-[preferred]
-# Use xdg-desktop-portal-gtk for every portal interface...
-default=gtk
-# ... except for the ScreenCast and Screenshot
-org.freedesktop.impl.portal.ScreenCast=wlr
-org.freedesktop.impl.portal.Screenshot=wlr
diff --git a/build-scripts/aur-git/sway.install b/build-scripts/aur-git/sway.install
deleted file mode 100644
index ef4fe013..00000000
--- a/build-scripts/aur-git/sway.install
+++ /dev/null
@@ -1,31 +0,0 @@
-post_install() {
-cat << EOD
-Sway requires additional setup for privilege escalation. Without this setup,
-sway will fail to start with session activation permission failures. Choose one
-of the two available options (In alphabetical, not recommended, order):
-
-1. polkit: This will make sway "just work" right after installation but may be
- a weightier solution than desired.
-
-2. seatd: Already required as a sway dependency, this is a lighter-weight
- solution but requires some user configuration: Enabling the service,
- adding your user to the "seat" group, then logging out/in again.
-
-Either option should provide the same functionality/stability. Refer to the
-Sway wiki page for information.
-EOD
-}
-
-post_upgrade() {
-cat << EOD
-Sway's necessary privileges can now be obtained through seatd as well as the
-incumbent polkit package. As such, polkit has been relegated to an optional
-dependency.
-
-Note that using seatd instead of polkit means that a user must be a part of the
-"seat" group: Otherwise, the user will not be able to achieve the appropriate
-privileged actions.
-
-For more information, refer to the Sway wiki page.
-EOD
-}