summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRyan Dwyer <[email protected]>2018-09-02 23:07:47 +1000
committerRyan Dwyer <[email protected]>2018-09-02 23:07:47 +1000
commit4ece26e511eaabca55fff216aa2f925d2c28ad44 (patch)
treec01cfd68037fcd30ea2573cf03e0b09f8050c331 /meson.build
parent7795f733d8c72f3467c2ac04e3d2633c79601935 (diff)
Add ld-library-path meson option
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 56f1141e..eb5cba84 100644
--- a/meson.build
+++ b/meson.build
@@ -120,6 +120,8 @@ else
endif
add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c')
+add_project_arguments('-D_LD_LIBRARY_PATH="@0@"'.format(get_option('ld-library-path')), language: 'c')
+
sway_inc = include_directories('include')
subdir('include')