diff options
author | Ricardo Steijn <[email protected]> | 2023-05-21 16:04:34 +0200 |
---|---|---|
committer | GitHub <[email protected]> | 2023-05-21 10:04:34 -0400 |
commit | 60e24c9cf4c9c729513c8103326e51c983414118 (patch) | |
tree | 602f1be81666c33171476eccce5468e6eef9dee6 /flake.nix | |
parent | 3c2e38be0356fa6feed3b28254f54efde54fe27d (diff) |
flake: remove libinput patch (#163)
This was backported to SwayFX in 3c2e38b
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 14 |
1 files changed, 12 insertions, 2 deletions
@@ -22,8 +22,18 @@ in { overlays.default = final: prev: { - swayfx-unwrapped = prev.sway-unwrapped.overrideAttrs - (old: { src = builtins.path { path = prev.lib.cleanSource ./.; }; }); + swayfx-unwrapped = prev.sway-unwrapped.overrideAttrs (old: { + src = builtins.path { path = prev.lib.cleanSource ./.; }; + patches = + let + removePatches = [ + "LIBINPUT_CONFIG_ACCEL_PROFILE_CUSTOM.patch" + ]; + in + builtins.filter + (patch: !builtins.elem (patch.name or null) removePatches) + (old.patches or [ ]); + }); }; packages = nixpkgs.lib.genAttrs targetSystems (system: |