summaryrefslogtreecommitdiff
path: root/build-scripts/aur-git/sway.install
diff options
context:
space:
mode:
authorErik Reider <[email protected]>2022-11-13 15:58:24 +0100
committerGitHub <[email protected]>2022-11-13 15:58:24 +0100
commit7990b32dd28be4e42979074212a3f2e7938aadee (patch)
tree6f56e161e747f17a8ccba1d3b7b784ead9866a9c /build-scripts/aur-git/sway.install
parentc82adeb7c09cf9200e6f0ca217443c9d8bcd20bd (diff)
Add PKGBUILD stable and -git, AUR publish and Arch build GitHub Actions (#31)
* Create AUR_publish.yml * Added PKGBUILD * Switched AUR publish addon * Added arch-build action * Remove useless step in arch-build * Checkout latest tag instead of master for Arch and Fedora publish actions * Added -git PKGBUILD and added wlroots < 0.16 as dependency * Checkout master before running swayfx-git aur script * Check build for stable PKGBUILD after -git version * Removed spaces in wlroots depends version
Diffstat (limited to 'build-scripts/aur-git/sway.install')
-rw-r--r--build-scripts/aur-git/sway.install31
1 files changed, 31 insertions, 0 deletions
diff --git a/build-scripts/aur-git/sway.install b/build-scripts/aur-git/sway.install
new file mode 100644
index 00000000..ef4fe013
--- /dev/null
+++ b/build-scripts/aur-git/sway.install
@@ -0,0 +1,31 @@
+post_install() {
+cat << EOD
+Sway requires additional setup for privilege escalation. Without this setup,
+sway will fail to start with session activation permission failures. Choose one
+of the two available options (In alphabetical, not recommended, order):
+
+1. polkit: This will make sway "just work" right after installation but may be
+ a weightier solution than desired.
+
+2. seatd: Already required as a sway dependency, this is a lighter-weight
+ solution but requires some user configuration: Enabling the service,
+ adding your user to the "seat" group, then logging out/in again.
+
+Either option should provide the same functionality/stability. Refer to the
+Sway wiki page for information.
+EOD
+}
+
+post_upgrade() {
+cat << EOD
+Sway's necessary privileges can now be obtained through seatd as well as the
+incumbent polkit package. As such, polkit has been relegated to an optional
+dependency.
+
+Note that using seatd instead of polkit means that a user must be a part of the
+"seat" group: Otherwise, the user will not be able to achieve the appropriate
+privileged actions.
+
+For more information, refer to the Sway wiki page.
+EOD
+}