summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/flake.nix b/flake.nix
index 4df374b..503394e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -25,23 +25,23 @@
in {
default = pkgs.mkShell {
name = "scenefx-shell";
+
+ inputsFrom = [ pkgs.wlroots_0_16 ];
+
nativeBuildInputs = with pkgs; [
cmake
meson
ninja
scdoc
pkg-config
-
- wayland
- wayland-scanner
- wayland-protocols
- wlroots_0_16
hwdata
- udev
- pixman
- libxkbcommon
- libdrm
];
+
+ shellHook = with pkgs; ''(
+ mkdir -p "$PWD/subprojects"
+ cd "$PWD/subprojects"
+ cp -R --no-preserve=mode,ownership ${wlroots_0_16.src} wlroots
+ )'';
};
});
};