diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 28 |
1 files changed, 12 insertions, 16 deletions
@@ -19,33 +19,29 @@ }; targetSystems = [ "aarch64-linux" "x86_64-linux" ]; - in - { + in { devShells = nixpkgs.lib.genAttrs targetSystems (system: - let - pkgs = pkgsFor system; - in - { + let pkgs = pkgsFor system; + in { default = pkgs.mkShell { name = "scenefx-shell"; - depsBuildBuild = with pkgs; [ pkg-config ]; - inputsFrom = [ pkgs.wlroots_0_16 ]; - nativeBuildInputs = with pkgs; [ cmake meson ninja + scdoc pkg-config + + wayland wayland-scanner - scdoc + wayland-protocols + wlroots_0_16 hwdata + udev + pixman + libxkbcommon + libdrm ]; - -# shellHook = with pkgs; ''( -# mkdir -p "$PWD/subprojects" -# cd "$PWD/subprojects" -# cp -R --no-preserve=mode,ownership ${wlroots_0_16.src} wlroots -# )''; }; }); }; |