summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorErik Reider <[email protected]>2024-01-08 09:23:32 +0100
committerGitHub <[email protected]>2024-01-08 09:23:32 +0100
commitb875d712407115b381915495e50875cfc523b76d (patch)
tree4f050bcb1a18179accd390749420d00714664691 /meson.build
parent6759e8da7ab53a46b0eb04e5045b8c67262c3a11 (diff)
parentcc83f41dbfc12af350c37f46677b82a64df801b8 (diff)
Merge pull request #27 from wlrfx/add_back_xkbcommon_dep
Meson fixes
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 7 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 070a07a..31da09e 100644
--- a/meson.build
+++ b/meson.build
@@ -92,14 +92,14 @@ wayland_server = dependency('wayland-server',
default_options: wayland_project_options,
)
-wlroots_options = [ 'examples=false' ]
+wlroots_options = [ 'examples=false', 'default_library=static' ]
wlroots_version = ['>=0.17.0', '<0.18.0']
-subproject(
+wlroots_is_sub = subproject(
'wlroots',
default_options: wlroots_options,
required: false,
version: wlroots_version,
-)
+).found()
wlroots = dependency('wlroots',
version: wlroots_version,
default_options: wlroots_options,
@@ -126,6 +126,7 @@ drm = dependency('libdrm',
'tests=false',
],
)
+xkbcommon = dependency('xkbcommon')
pixman = dependency('pixman-1',
version: '>=0.42.0',
fallback: 'pixman',
@@ -139,6 +140,7 @@ wlr_deps = [
wlroots,
wayland_server,
drm,
+ xkbcommon,
pixman,
math,
rt,
@@ -150,6 +152,8 @@ subdir('render')
subdir('types')
subdir('util')
+subdir('include')
+
scenefx_inc = include_directories('include')
lib_scenefx = library(