summaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
authoramy <[email protected]>2024-10-24 12:46:38 -0500
committerGitHub <[email protected]>2024-10-24 12:46:38 -0500
commit1f7a881b519541394fb27bfe244f05f723415729 (patch)
tree449b04ebc0c334f3d1ba6a425e738331a80e4249 /examples/meson.build
parent6fe9f31f55a291bf738c8b76b75190a4ac909df1 (diff)
parentbe5a78ac298f3b23c9955022ad35a18180a5894a (diff)
Merge branch 'wlrfx:main' into main
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
new file mode 100644
index 0000000..da32934
--- /dev/null
+++ b/examples/meson.build
@@ -0,0 +1,24 @@
+# Only needed for drm_fourcc.h
+libdrm_header = dependency('libdrm').partial_dependency(compile_args: true, includes: true)
+
+compositors = {
+ 'scene-graph': {
+ 'src': 'scene-graph.c',
+ 'proto': ['xdg-shell'],
+ },
+}
+
+foreach name, info : compositors
+ extra_src = []
+ foreach p : info.get('proto', [])
+ extra_src += protocols_server_header[p]
+ endforeach
+
+ executable(
+ name,
+ [info.get('src'), extra_src],
+ dependencies: [wlroots, scenefx, libdrm_header, info.get('dep', [])],
+ build_by_default: get_option('examples'),
+ )
+endforeach
+