summaryrefslogtreecommitdiff
path: root/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r--common/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt
index a40f096d..38767249 100644
--- a/common/CMakeLists.txt
+++ b/common/CMakeLists.txt
@@ -6,3 +6,10 @@ add_library(sway-common
readline.c
stringop.c
)
+
+if(Backtrace_FOUND)
+ set_target_properties(sway-common
+ PROPERTIES
+ COMPILE_FLAGS "-include ${Backtrace_HEADER}"
+ )
+endif()